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INTRODUCTION 

Welcome to the New World ERP SSRS Lab.  New World ERP uses Microsoft® SQL Server Reporting 

Services (SSRS) as the primary technology for generating standard reports and forms.  The SSRS 

toolset provides a streamlined means of report creation and customization, as well as a simplified 

method of report deployment.  In this lab, we will explore the possibilities available with SSRS, and 

provide you with the basics to create and enhance reports for your own organization. 

 

REPORT BUILDER 

Microsoft® Report Builder is a report authoring tool that features a Microsoft® Office-like environment 

with an array of useful report objects such as tables, charts, and text boxes.  This application is a free 

download and only requires rights to your SQL Server Reporting Services and read access to a 

database.  In this session, we will be utilizing Report Builder Version 15.0.20073.0. 

 

 

REPORT BUILDER VERSUS VISUAL STUDIO 

This lab will utilize Microsoft® Report Builder for all exercises.  While Microsoft® Visual Studio can be 

used to produce the same results, it is geared more towards software developers rather than business 

analysts.  Visual Studio includes additional features such as integration with source control systems, 

intelliSense for report expressions, and the ability to develop and utilize custom functions within the 

report. 

 

 

ASSUMPTIONS 

Attendees are expected to have a prior experience maintaining SSRS reports and SQL queries. 
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OBJECTIVES 

After completing this lab, you will be familiar with… 

• Images 

• Interactive sorting 

• Expressions 

• Merging cells 

• Filtering 

• Parameters 

• Hyperlinks 
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EXERCISE – CREATE AN EMPLOYEE INFORMATION REPORT 

Requirements 

• Report Builder installed on the client machine 

• Rights to access SQL Server Reporting Services where New World ERP is installed 

• Read-only access to the New World ERP database 

Start Report Builder 

1. Start by running Report Builder 

a. Click into the search field next to the Start menu in the lower left corner of the screen 

b. Type “report builder” into the search field 

c. Click the Report Builder App to open it 
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2. In the Getting Started window, select New Report > Table or Matrix Wizard 

 

3. When prompted to Choose a Dataset, select Create a Dataset and click <Next> 
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Create the Data Source 

The Data Source is the connection to the database will be used for report data. 

1. In the Choose a Connection to the Data Source window, click the <New> button to create a new 

data source 

a. Enter NWERP in the Name field 

b. Click the <Build> button to configure the DB connection 

 

i. Server name: 3.214.108.135 

ii. Use SQL Server Authentication with  

1. User name: ssrs 

2. Password: ssrs 

iii. Check Save my password 

iv. Select or enter a database name: NWERPLAB_ERP 

v. Click <OK> to close the Connection Properties popup 

c. Click <OK> to close the Data Source Properties window 

2. From the Connection to the Data Source window, confirm your NWERP data source is selected 

and click the <Next> button 
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It is also possible to connect to an existing NWERP Data Source used by your 

standard NWERP reports, rather than creating a new database connection in every 

SSRS report.  For additional details, please refer to the Appendix. 

 

Create the Dataset 

The Dataset contains the rows and columns of data that will be displayed in the report.  In our example 

we will be retrieving several employee-related fields. 

1. Click the <Edit as Text> button at the top of the Design a Query window 

2. Locate the 1-EmployeeInfoDataSet.txt file in the Windows Desktop > SSRS folder and double-

click to open it in Notepad 

a. Highlight all of the text (Ctrl + A) and Copy it (Ctrl + C) to your clipboard 

b. In the Report Builder Design a Query window, Paste the text (Ctrl + V) into the blank text 

field below the header 

 
3. Click the Run icon  to confirm that your query returns data 

 
4. Click <Next> 
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Select the Data and Prepare the Body 

1. From the Arrange Fields window 

a. Drag the following fields to the Values box 

i. EmployeeName 

ii. EmployeeNumber 

1. The EmployeeNumber field will be prefaced with the word “Sum” (i.e. 

Sum(EmployeeNumber))  

a. Click the field to highlight it 

b. Click the down arrow  to the right of the field name and click 

Sum to deselect it 

iii. EmployeeType 

iv. PositionNumber 

1. The PositionNumber field will be prefaced with the word “Sum” (i.e. 

Sum(PositionNumber))  

a. Click the field to highlight it 

b. Click the down arrow  to the right of the field name and click 

Sum to deselect it 

v. PositionTitle 

vi. BenefitGroup 

b. Drag the following fields to the Row groups box 

i. Department 
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c. When complete, it should look like this 

 

d. Click <Next> 

2. From the Choose the layout window 

a. Check Show subtotal and grand totals 

i. Select Stepped, subtotal above 

b. Check Expand/collapse groups 

 

3. Click <Next> 
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4. Click <Finish> 

 

5. Delete all the Sum fields and the “Total” text from the group header and footer by clicking on 

the cell and pressing the <Delete> key on your keyboard 

 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  

 

  



 

 

 11 

Add an Image 

1. Resize the report to allow room for a logo and make it more readable 

a. Widen the Employee Name and Position Title columns so that the data printed will be 

more likely to fit on one line 

b. Select the Employee Name and Position Title columns, then click the Left align button 

to align the text in both columns to the left 

 

c. Move the tablix down to make more room 

d. Add the title “Employee Information Report“ and shrink the width of its text box 
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2. In the Report Data tray on the left, right-click Images, then select Add Image 

 

3. Browse to the Logo.jpg file in the Windows Desktop > SSRS folder and double-click it to open 

bring it into the report 

 

4. Drag the Logo onto your report in the upper right-hand corner and an Image Properties window 

will appear 
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5. Select the Size tab on the left side of the Image Properties window 

a. Under Display, select Original size 

 

6. Click <OK> 

7. Move the tablix down more if the logo overlaps it 

 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  

 



 

 

 14 
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Building Expressions 

1. Right-click on the Department text box in the group header and select Expression 

 

a. You should see =Fields!Department.Value 

b. Change it to the following 

=Fields!Department.Value & “ – “ & Fields!DepartmentDescription.Value & “  (“ &  

Count(Fields!EmployeeID.Value) & “ employees)” 

NOTE: you can copy this text from the file 2-DepartmentExpression.txt located in the Windows 

Desktop > SSRS folder 

 



 

 

 16 

 

A shortcut to typing out the field names in expressions is to select Fields in the 

Category window, then double-click the column name in the Values window. 

c. Click <OK> 

2. You should notice that the cell previous with [Department] in it now shows as «Expr» 

 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  

 

 

Merging Cells 

Notice above now that you added the Department Description, the cell wraps and looks odd 

1. Click the new Department cell with the «Expr» in it within the group header 

2. Hold the <Shift> key down on your keyboard 

3. Click the cell in the last column of the report that is in the same row (all cells in that row should 

now be selected) 
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4. Right-click somewhere within the selected cells and select Merge Cells 

 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  

5. Notice the Department no longer wraps 

 

6. Conversely, you can right-click on a merged cell and select Split Cells to “un-merge” the cells 
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Interactive Sorting 

1. Right-click the column header named Employee Name and select Textbox Properties 

 

2. Select the Interactive Sorting tab on the left in the Text Box Properties windows 

a. Check Enable interactive sorting on this text box 

b. Sort by: [EmployeeName]  

 

3. Click <OK> 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  
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4. You will notice the Employee Name column has an up and down arrow on it now 

 

5. Click that arrow to sort the report by Employee Name within each department group 

 

Filtering 

1. Click anywhere on the table and right-click any gray edge of the tablix and select Tablix 

Properties 

 

2. Select the Filters tab on the left side of the Tablix Properties window 

3. Click <Add> 

a. Expression = [EmployeeStatus] 

b. Operator “=” 

c. Value = A 

4. Click <OK> 
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- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  

 

5. You will notice that the list of employees in the 001 - Council department has reduced from 59 

to 8, since it now only shows active (A) employees 

 

 

Creating Parameters 

1. In the Report Data tray on the left, right-click Parameters, then select Add Parameter 
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2. In the Report Parameter Properties window, enter Department into the Name and Prompt fields 

 

3. Click <OK> 

4. In the Report Data tray on the left, expand Datasets, right-click DataSet1, then select Dataset 

Properties 
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5. In the Dataset Properties window pop up, add a WHERE clause to the end of the query string 

WHERE EPJ.OrgStructureCodeConcatenated IN (@Department) 

NOTE: you can copy this text from the file 3-WhereClause.txt located in the Windows Desktop > SSRS 

folder 

 

6. Select the Parameters tab on the left 

a. A parameter named @Department should have been already added for you 

b. Select [@Department] for the Parameter Value 

i. This connects the Dataset’s parameter to the report parameter you created 

earlier 

 

c. Click <OK> 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  
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7. A Department parameter will appear at the top 

a. Enter 001 

 

b. Click <View Report> 

8. The report should just return results having the department 001 

 

 

List Parameters Using Database Values 

1. In the Report Data tray on the left, right click on the Datasets folder, then select Add Dataset 

 

2. In the Datatset Properties window enter the following 

a. Name: Departments 

b. Select Use a dataset embedded in my report 

c. Data source: NWERP 

d. Select Text 

i. Locate the 4-DepartmentDataSet.txt file in the Windows Desktop > SSRS folder 

and double-click to open it in Notepad 
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1. Highlight all of the text (Ctrl + A) and Copy it (Ctrl + C) to your clipboard 

2. Paste (Ctrl + V) the text into the Dataset Properties Query window  

 

3. Click <OK> 

4. In the Report Data tray on the left, expand Parameters, right click Department, then select 

Parameter Properties 

 

5. Check Allow multiple values 
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6. Select the Available Values tab on the left 

a. Select Get values from a query 

b. Dataset: Departments 

c. Value field: Department 

d. Label field: DepartmentDescription 

 

7. Click <OK> 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  
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8. You will notice the Department parameter now appears as a drop down where you can select 

multiple departments 

 

 

Default Parameters 

1. In the Report Data tray on the left, right click on the Datasets folder, then select Add Dataset 
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2. In the Datatset Properties window enter the following 

a. Name: DateDataSet 

b. Select Use a dataset embedded in my report 

c. Data source: NWERP 

d. Select Text 

i. Locate the 5-DateDataSet.txt file in the Windows Desktop > SSRS folder and 

double-click to open it in Notepad 

1. Highlight all of the text (Ctrl + A) and Copy it (Ctrl + C) to your clipboard 

2. Paste (Ctrl + V) the text into the Dataset Properties Query window  

 

3. Click <OK> 
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4. In the Report Data tray on the left, right-click Parameters, then select Add Parameter 

 

5. In the Report Parameter Properties window 

a. Name: EffectiveDate 

b. Prompt: Effective Date 

c. Data type: select Date/Time 
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6. Select the Default Values tab on the left 

a. Select Get values from a query 

b. Dataset: DateDataSet 

c. Value field: Today 

 

7. Click <OK> 

8. In the Report Data tray on the left, expand Datasets, right-click DataSet1, then select Dataset 

Properties 
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9. In the Dataset Properties window pop up, remove the first 2 lines of the query string 

DECLARE @AsOfDate DATETIME 

SET @AsOfDate = GETDATE() 

 

10. Select the Parameters tab on the left 

a. A parameter named @AsOfDate should have been already added 

b. Select [@EffectiveDate] for the Parameter Value 

i. This connects the Dataset’s parameter to the report parameter you created 

earlier 

c. Click <OK> 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  

 

11. An Effective Date parameter will appear at the top defaulting in today’s date 

 

The report will now print the employees’ information as of the Effective Date you enter 
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12. In the Report Data tray on the left, expand Parameters, right click Department, then select 

Parameter Properties 

 

13. Select the Default Values tab on the left 

a. Select Get values from a query 

b. Dataset: Departments 

c. Value field: Department 

 

14. Click <OK> 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  

 

  



 

 

 32 

15. You will notice the Department parameter now appears auto selects every department from the 

drop down by default 

 

At this point, the report will automatically generate because default values have been specified for 

all parameters 

 

 

Link to New World ERP 

1. Right-click on the [EmployeeName] text box in the group header and select Text Box 

Properties 
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2. Select the Action tab on the left 

a. Select Go to URL 

b. Select URL 

i. Locate the 6-EmployeeURLExpression.txt file in the Windows Desktop > SSRS 

folder and double-click to open it in Notepad 

1. Highlight all of the text (Ctrl + A) and Copy it (Ctrl + C) to your clipboard 

2. Paste (Ctrl + V) the text into the Text Box Properties Select URL field  

 
Note: This is the URL to the Workforce Administration page.  Many of the URLs in the software end with 

a unique ID.  In this case, it’s the EmployeeID from the database. 

 

c. Click <OK> 

 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  

 

3. If you run the report and hover over one of the employees in the Employee Name column, the 

mouse pointer should change 
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4. If you click on the employee, it will take you into the Workforce Administration page for that 

employee 

a. Login for New World ERP 

i. User: lab*  

1. where * represents your laptop station identifier (1 through 50) 

2. example lab11 

ii. Password: connect123 

 

 

Expand/Collapse All 

1. In the Report Data tray on the left, right-click Parameters, then select Add Parameter 

 
2. In the Report Parameter Properties window 

a. Name: ExpandCollapse 

b. Prompt: Expand/Collapse 
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3. Select the Available Values tab on the left 

a. Select Specify values 

b. Click <Add> 

i. Label: Expand All 

ii. Value: Expand 

c. Click <Add> 

i. Label = Collapse All 

ii. Value = Collapse 

 
4. Select the Default Values tab on the left 

a. Select Specify values 

b. Click <Add> 

i. Value: Collapse 

 
5. Click <OK> 

6. Click somewhere in the Tablix revealing the gray border 
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7. Right click on the Details row  in gray border on the left side of the Tablix and select Row 

Properties 

 
8. Select Visibility tab on the left 

a. Select Show or hide based on an expression 

b. Click the button to add an Expression 

 
i. Enter the following in the expression 

=IIF(Parameters!ExpandCollapse.Value="Expand", False, True) 
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ii. Click <OK> 

 
c. Click <OK> 

9. Select the View tab at the top of Report Builder  

10. Check Properties to display the Properties tray on the right 

 
11. In your Tablix, select the Department group header cell (the cell we merged earlier) 
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12. Select the property titled InitialToggleState near the bottom of the Properties tray under the 

Visibility section 

 
13. Enter the following in the expression, replacing the false text 

=IIF(Parameters!ExpandCollapse.Value="Expand", True, False) 

 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  

 

14. Select Expand/Collapse = Expand All 
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15. Click <View Report> 

Notice all Department groups are expanded 
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EXERCISE – UPDATE AN EXISTING REPORT TO ALLOW DATA 
ENTRY 

Free Form Entry 

1. Open an existing report by clicking File > Open in the upper left corner 

 
a. Locate the EmployeeVerificationForm.rdl file in the Windows Desktop > SSRS folder 

and double-click to open it in Report Builder 
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- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  

 

2. Select any employee and click <View Report> 

3. Click the Print Layout icon to view the report in a print preview mode 
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This is a basic Employment Verification Form with an area for Remarks. Instead of writing in remarks by 

hand, we’re going to modify this report to allow you to enter them through SSRS. 
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4. In the Report Data tray on the left, right-click Parameters, then select Add Parameter 

 
5. In the Report Parameter Properties window, enter Remarks into the Name and Prompt fields. 

 
6. Click <OK> 

 
  



 

 

 44 

7. Enter the following into the Expression window 

a. =Join(Parameters!Remarks.Label, chr(10)) 

8. Click <OK> 

 

 

- - -  PREVIEW BREAK  - - - 

 
Click the Run icon to preview your report – Click Design when finished.  

 

9. Click the drop-down arrow next to the new Remarks parameter 

10. Click inside the area that opens and begin typing a message 

 
Note: You can press enter to go to a new line and enter as much text as you like 

 

11. Click <View Report> 
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APPENDIX 

Data Sources 

When New World ERP reports have been deployed to an SSRS Report Server, a Data Source is created 
to allow the standard reports to connect to the New World ERP Database.  This Shared Data Source 
should be used when creating new or modifying existing reports. 
 
In Report Builder, instead of creating a new data source, you can <Browse> for an existing one. 
After clicking the <Browse> button in the Data Source Properties menu, enter the report server URL 
into the file name field. The URL is structures as follows… 
http://SSRS Server Name or IP Address/reportserver 

 
Press <Enter> or click the <Open> button to browse the Report Server directory.  You should see the 
folder where the New World ERP SSRS reports were deployed during the initial installation. 

 

Located and select the data source icon  and click <Open>.  The data source will typically be named 
LogosDB. 

http://ssrs/
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SSRS Report Services URL 

The SSRS Report Server (i.e. Reporting Services) is generally installed on the New World ERP 
Database Server.  The Reporting Services directory tree can be accessed using one of the following 
URLs: 
 

http://ServerName/reports 
 
Use this path when directly browsing the SSRS folders via Internet Explorer, setting security, 
uploading new reports, creating folders, etc. 
 

http://ServerName/ReportServer 
 
This path provides a basic navigation which can be used for browsing and uploading reports via Report 
Builder.  

 

SSRS Report Services URL (Named Instances of SQL) 

If using a named instance of SQL, the URL must include an underscore followed by the name of the 
instance.  In the example below, the SQL instance is called “finance.” 
 

http://ServerName/reports_finance 

http://servername/reports
http://servername/ReportServer
http://servername/reports_finance
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Direct Links to Custom Reports 

Once the report is published, a direct link to execute it can be obtained with the following URL 
structure: 
 
http://ServerName/ReportServer/Pages/ReportViewer.aspx?%2fFolderName%2fCustomReportName 
 
If there are multiple folders in the directory, they should be ordered sequentially.  Use “%2f” instead of 
‘/’ between folder names.  Spaces in the folder names must be separated with a + sign. 
 
Example: 
 
http://NWSDB/ReportServer/Pages/ReportViewer.aspx?%2fCustom+Reports%2f 
Finance+Department%2f BudgetAnalysis 

 

Query Designer 

When building a dataset, the query can be built from the Report Builder Query Designer tool.  This 
feature can be accessed from the Dataset (Query) Properties, by clicking the <Query Designer> 
button. 

  
 

Query Designer provides a visual query mechanic for those not familiar with SQL syntax. 
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It has four components: 
 

1. Database View 

The Database View can be drilled into through the folder structure on the left. 
 

 

          

 

Tables and Views are categorized into folders, based on their applied schema (i.e. FM, HR, UT, 
CD), although most of the classic tables can be currently found in the DBO (database object) 
schema. 
 
A table can be selected as a whole or by selecting individual fields.  Fields will either be used in 
the report output or to link to other tables. 
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2. Selected Fields 

Fields selected from the Database View will populate the Selected Fields window.  If a field is 
represented by more than one table, it will appear as Table Name Field Name. 
 

The Selected Fields window will allow you to move, delete, or group fields.  
 

 
 

If the fields are grouped, an aggregate is selected from the right-hand column.  
Example: The “sum” aggregate applied to the TransactionAmount will sum the transactions 
where all other grouped fields share a common set of values. 
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3. Relationships 

Relationships represent the joins between one or more tables.  They are joined on a key that 
the tables share. It is common to have many joins in a single query. 

The Relationships are generally collapsed by default.  The Auto Detect feature  
serves to build the table joins automatically.  This setting can be turned off by clicking the 

button and manual joins can be created, if desired. The  icon can be used to expand this 
section.  You can also use the expand toggle to view the automatically created joins. 
 

 
 

4. Applied Filters 

Filters   can apply a measured constraint or restrict the query to a specific set of values. 
The filter may indicate that a specific value should be validated, or it can be used as a 
parameter, which will allow the end-user to specify the criteria. 
 

 

 
You can view the SQL syntax for your query at any time by clicking the <Edit As 
Text> button. 
 

 
Before completing your dataset, use the <Run Query> button to confirm it 
returns the values you were expecting.  This will also help to catch any errors, 
due to improper query design. 

 


